Slower workflow execution
Incident Report for GlobiFlow for Podio
Resolved
GlobiFlow performance has remained steady.
Posted about 1 year ago. Apr 23, 2018 - 12:33 EDT
Monitoring
GlobiFlow performance has improved and we will continue monitoring.
Posted about 1 year ago. Apr 23, 2018 - 09:40 EDT
Investigating
We are investigating delays for some customers. Stay tuned.
Posted about 1 year ago. Apr 23, 2018 - 09:05 EDT