Users cannot login into GlobiFlow
Incident Report for GlobiFlow for Podio
Resolved
A configuration issue in the Podio load balancer caused this outage. This has been fixed.
Posted Mar 10, 2020 - 02:59 EDT
Update
We are continuing to investigate this issue.
Posted Mar 10, 2020 - 02:29 EDT
Investigating
We are currently investigating this issue.
Posted Mar 10, 2020 - 02:27 EDT